码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 1102 prime算法

时间:2015-03-28 17:23:35      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:prime算法

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15475    Accepted Submission(s): 5907


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source
 
//考查知识点:prime算法 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0xfffffff
int n;
int map[110][110],visit[110],dis[110];
void prime()
{
	int i,j,sum=0,pos=1,min;
	for(i=1;i<=n;++i)
	{
		dis[i]=map[1][i];
	}
	visit[1]=1;
	dis[1]=0;
	for(i=1;i<n;++i)
	{
		min=inf;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&dis[j]<min)
			{
				min=dis[j];
				pos=j;
			}
		}
		sum+=min;
		visit[pos]=1;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&dis[j]>map[pos][j])
			dis[j]=map[pos][j];
		}
	}
	printf("%d\n",sum);
}
int main()
{
	int i,j;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				map[i][j]=inf;
			}
		}
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				scanf("%d",&map[i][j]);
			}
		}
		int m,a,b;
		scanf("%d",&m);
		while(m--)
		{
			scanf("%d%d",&a,&b);
			map[a][b]=map[b][a]=0;
		}
		memset(visit,0,sizeof(visit));
		prime();
	}
	return 0;
} 


hdu 1102 prime算法

标签:prime算法

原文地址:http://blog.csdn.net/ice_alone/article/details/44702269

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!