码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 1789 Doing HomeWork Again (贪心算法)

时间:2015-03-29 18:03:41      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1789

/*Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7903    Accepted Submission(s): 4680


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
 

Sample Output
0
3
5
 

Author
lcy
 

Source
2007省赛集训队练习赛(10)_以此感谢DOOMIII
 
*/
//贪心算法
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000 + 100;
struct Node{
    int d, s;
};
Node node[maxn];
int Mark[maxn];
bool cmp(Node a, Node b){
    return a.s > b.s;
}
int main()
{
    int t, n;
    while(~scanf("%d", &t)){
        while(t--){
            scanf("%d", &n);
            memset(Mark, 0, sizeof(Mark));
            for(int i = 1; i <= n; i++) scanf("%d", &node[i].d);
            for(int i = 1; i <= n; i++) scanf("%d", &node[i].s);
            sort(node+1, node+n+1, cmp);
            int i, j, cnt = 0;
            for(i = 1; i <= n; i++){
                for(j = node[i].d; j >= 1; j--){
                    if(!Mark[j]){
                        Mark[j] = 1;
                        break;
                    }
                }
                if(j == 0) cnt += node[i].s;
            }
            printf("%d\n", cnt);
        }
    }
    return 0;
}

 

hdu 1789 Doing HomeWork Again (贪心算法)

标签:

原文地址:http://www.cnblogs.com/ACFLOOD/p/4375914.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!