标签:acm java hdu 简单模拟 农夫山泉
To and Fro
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5161 Accepted Submission(s): 3573
Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if
the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down
t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x
Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.
Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as
toioynnkpheleaigshareconhtomesnlewx
Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set
is followed by a line containing a single 0, indicating end of input.
Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
Sample Input
5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0
Sample Output
theresnoplacelikehomeonasnowynightx
thisistheeasyoneab
Source
Recommend
Ignatius.L | We have carefully selected several similar problems for you:
1196 1073 1161 1039 1020
比起动态规划什么的,这个就是水果了。因为没有转弯没有坑,直来直往就行.
首先用二维数组按照下面这种形式存储.这个存储方式是奇数行从左往右存,偶数行从右往左边存,这应该很好理解,用一个判断语句就可以做到.
然后按照从上到下,即外层循环控制列数,内层循环控制行数输出就行了!
import java.io.*;
import java.util.*;
public class Main
{
public static void main(String[] args)
{
Scanner input = new Scanner(System.in);
while (input.hasNext())
{
int n = input.nextInt();
if(n==0) break;
input.nextLine();
String str = input.nextLine();
char c1[] = str.toCharArray(); // 把每个字符单个存起来
char c2[][] = new char[1010][1010];
int line = c1.length / n; //记录行数
int k = 0; // 记录c1字符的位数
for (int i = 0; i < line; i++)
{
if (i % 2 == 1)
{
for (int j = n - 1; j >= 0; j--)
{
c2[i][j] = c1[k++];
}
}
else
{
for (int j = 0; j < n; j++)
{
c2[i][j] = c1[k++];
}
}
}
for (int j = 0; j < n; j++)
{
for (int i = 0; i < line; i++)
{
System.out.print(c2[i][j]);
}
}
System.out.println();
}
}
}
HDU-1200-To and Fro(Java农夫山泉+简单模拟)
标签:acm java hdu 简单模拟 农夫山泉
原文地址:http://blog.csdn.net/qq_16542775/article/details/44804799