码迷,mamicode.com
首页 > 编程语言 > 详细

hdoj 1686 Oulipo(KMP算法)

时间:2015-04-03 09:40:06      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:算法   acm   kmp   数据结构   

Oulipo

http://acm.hdu.edu.cn/showproblem.php?pid=1686
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5903    Accepted Submission(s): 2370


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
1 3 0
 

Source
 

//高大上的KMP算法(数据结构P82-83  严蔚敏版)

#include<cstdio>

#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
char w[10005];
char t[1000005];
int nextval[10005];


void get_nextval(char s[])//求模式串S的nextval函数值并存入到nextval[]中
{
int i=0,j=-1;
nextval[0]=-1;
while(i<strlen(s))
{
  if(j==-1||s[i]==s[j])
  {
  ++i;
  ++j;
  if(s[i]!=s[j])
   nextval[i]=j;
   else
    nextval[i]=nextval[j];
  }
  else
    j=nextval[j];
}
}


int KMP(char s[],char t[])//利用模式串t的nextval函数求t的主串s
{
int ls=strlen(s);
int lt=strlen(t);
int i=0,j=0,len=0;

while(i<=ls&&j<=lt)
{
 if(j==-1||s[i]==t[j])//继续比较后继字符
 {  ++i;++j; }
 else
   j=nextval[j]; //  模式串向右移动
 if(j==lt)//通过nextval[]求得的j如果和模式串的长度相等就说明模式串在主串中出现了;
 {
  len++;
  j=nextval[j];
 }
}
return len;
}

int main()
{
  
  int n;
  scanf("%d",&n);
  while(n--)
  {
  scanf("%s",w);
  scanf("%s",t);
  get_nextval(w);
  int len=KMP(t,w);
printf("%d\n",len); 
  }
  return 0;



 

hdoj 1686 Oulipo(KMP算法)

标签:算法   acm   kmp   数据结构   

原文地址:http://blog.csdn.net/lh__huahuan/article/details/44834383

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!