标签:acm c++ 杭电 算法 编程
Goldbach‘s Conjecture
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4976 Accepted Submission(s): 1901
Problem Description
Goldbach‘s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of
all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.
A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2)
and (p2, p1) separately as two different pairs.
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
Output
Each output line should contain an integer number. No other characters should appear in the output.
Sample Input
Sample Output
如果必然能写成两素数和那么先判断第一个数m是否为素数,且n-m也为素数,计时器加1,注意不要重复。
#include<iostream>
#include<cmath>
using namespace std;
int ls[40000];
void A()
{
int i,j;
for(int k=0;k<=40000;k++)
ls[k]=1;
for( i=2;i<=sqrt(40000);i++)
{
if(ls[i])
{
for( j=i+i;j<40000;j+=i)
ls[j]=0;
}
}
}
int main()
{
int n;
A();
while(cin>>n,n)
{
int count=0;
for(int m=2;m<=n/2;m++)
if(ls[m]&&ls[n-m])
count++;
cout<<count<<endl;
}
return 0;
}
杭电 HDU ACM 1397 Goldbach's Conjecture
标签:acm c++ 杭电 算法 编程
原文地址:http://blog.csdn.net/lsgqjh/article/details/44886323