码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2299 Ultra-QuickSort(逆序数 树状数组)

时间:2015-04-12 10:42:57      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:树状数组

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 45960   Accepted: 16702

Description

技术分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source



数据比较大,设置一个pos相当于离散


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 500005

int a[N],c[N];
int n;

struct stud{
 int pos,x;
   bool operator < (const stud &b)const
   {
	  return x<b.x;
   }
}f[N];

int lowbit(int x)
{
	return x&(-x);
}

void update(int x)
{
	while(x<=n)
	{
		c[x]++;
		x+=lowbit(x);
	}
}

int sum(int x)
{
   int s=0;
   while(x)
   {
   	 s+=c[x];
   	 x-=lowbit(x);
   }
   return s;
}

int main()
{
	int i,j;
	while(sf(n),n)
	{
		for(i=1;i<=n;i++)
		{
			sf(f[i].x);
			f[i].pos=i;
		}
        sort(f+1,f+n+1);
	    ll ans=0;
	    mem(c,0);
	    for(i=1;i<=n;i++)
		{
			ans+=sum(n)-sum(f[i].pos-1);
			update(f[i].pos);
		}
      pf("%I64d\n",ans);
	}
   return 0;
}







POJ 2299 Ultra-QuickSort(逆序数 树状数组)

标签:树状数组

原文地址:http://blog.csdn.net/u014737310/article/details/45007669

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!