码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2352 star (树状数组)

时间:2015-04-12 13:27:50      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:树状数组

Language:
Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 35318   Accepted: 15326

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
技术分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source



这一个题我发现了 当x=0时,x+lowbit(x)=0;所以必须x++,否则update(0)就会死循环




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 32005

struct stud{
 int x,y;
 bool operator <(const stud b) const
 {
     if(x==b.x)
       return y<b.y;
     return x<b.x;
 }
}f[15005];

int ans[N];
int c[N];
int ma,n;

inline int lowbit(int x)
{
    return x&(-x);
}

void update(int x)
{
    while(x<=ma)
    {
        c[x]++;
        x+=lowbit(x);
    }
}
int Sum(int x)
{
    int s=0;
    while(x)
    {
        s+=c[x];
        x-=lowbit(x);
    }
   return s;
}

int main()
{
    int i,j;
   
    sf(n);
    mem(ans,0);
    ma=-1;
    for(i=0;i<n;i++)
    {
         sff(f[i].x,f[i].y);
         f[i].y++;
         ma=max(ma,f[i].y);
    }

    sort(f,f+n);
    mem(c,0);

    for(i=0;i<n;i++)
    {
        int t=Sum(f[i].y);
        ans[t]++;
        update(f[i].y);
    }
    for(i=0;i<n;i++)
        pf("%d\n",ans[i]);

    return 0;

}


POJ 2352 star (树状数组)

标签:树状数组

原文地址:http://blog.csdn.net/u014737310/article/details/45008763

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!