标签:
点击打开链杭电1379
Problem Description
One measure of ``unsortedness‘‘ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC‘‘, this measure is 5, since D is greater than four letters
to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG‘‘ has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM‘‘ has 6 inversions (it is
as unsorted as can be--exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness‘‘, from ``most sorted‘‘ to ``least sorted‘‘.
All the strings are of the same length.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string
of length n.
Output
Output the list of input strings, arranged from ``most sorted‘‘ to ``least sorted‘‘. If two or more strings are equally sorted, list them in the same order they are in the input file.
Sample Input
1
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
面向对象编程,虽然看上去麻烦,但思路清晰。
import java.util.*;
class Main{
public static void main(String[] args){
int n,m,i,j,t;
String str;
Scanner sc=new Scanner(System.in);
t=sc.nextInt();
while(t-->0){
n=sc.nextInt();
m=sc.nextInt();
sc.nextLine();
StringSort[] strs=new StringSort[m];
for(i=0;i<m;i++){
str=sc.nextLine();
strs[i]=new StringSort(str);
}
for(i=0;i<m;i++){
strs[i].measure();
}
sort(strs);
for(i=0;i<m;i++){
System.out.println(strs[i].str);
}
}
}
public static void sort(StringSort[] strs){
for(int i=0;i<strs.length-1;i++){
int minIndex=i;
for(int j=i+1;j<strs.length;j++){
if(strs[j].count<strs[minIndex].count){
minIndex=j;
}
}
if(minIndex!=i){
StringSort temp=strs[i];
strs[i]=strs[minIndex];
strs[minIndex]=temp;
}
}
}
}
class StringSort{
String str;
int count;
public StringSort(String str){
this.str=str;
this.count=0;
}
public void measure(){
for(int i=0;i<str.length()-1;i++){
for(int j=i+1;j<str.length();j++){
if(str.charAt(i)>str.charAt(j)){
count++;
}
}
}
}
}
杭电1379(DNA Sorting)java面向对象编程
标签:
原文地址:http://blog.csdn.net/u011479875/article/details/45080309