码迷,mamicode.com
首页 > 编程语言 > 详细

(KMP 1.4)hdu 3746 Cyclic Nacklace(使用next数组来求循环节的长度——求一个字符串需要添加多少个字符才能使该字符串的循环节的个数>=2)

时间:2015-04-18 17:51:02      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3387    Accepted Submission(s): 1549


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:
技术分享

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
3 aaa abca abcde
 

Sample Output
0 2 5
 

Author
possessor WC
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  3336 1358 2222 3068 2896 


题目大意:

              对于一个给定的字符串,需要添加多少个字符才能使该字符串的循环节的个数>=2。


题目分析:

              KMP。简单题。


这道题需要记住以下几点:

1、len-next[len]   :  该字符串的最小循环节的长度

2、如果len%(len-next[len]) == 0 ,表明该字符串由循环节组成,那么循环节的个数是len/(len-next[len])。



代码如下:

/*
 * hdu3746.cpp
 *
 *  Created on: 2015年4月18日
 *      Author: Administrator
 */



#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 100001;

int m;//目标串的长度

char pattern[maxn];//模式串
int nnext[maxn];//next数组.直接起next可能会跟系统中预定的重名.

/*O(m)的时间求next数组*/
void get_next() {
	m = strlen(pattern);

	nnext[0] = nnext[1] = 0;
	for (int i = 1; i < m; i++) {
		int j = nnext[i];
		while (j && pattern[i] != pattern[j])
			j = nnext[j];
		nnext[i + 1] = pattern[i] == pattern[j] ? j + 1 : 0;
	}
}


int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%s",pattern);

		get_next();

		int len = strlen(pattern);//计算模式串的长度

		/**
		 * 如果该字符串已经是由多个循环节组成.
		 * len%(len-nnext[len]) == 0 : 该字符串由循环节组成
		 * (len != len-nnext[len]) :字符串的长度不等于循环节的长度
		 *
		 * ----->该字符串本身已经由多个循环节组成
		 */
		if(len%(len-nnext[len]) == 0 && (len != len-nnext[len]) ){
			printf("0\n");//那这时候需要添加的字符的数量是0
		}else{
			/**
			 * len-nnext[len] : 循环节的长度
			 * len%(len-nnext[len] : 字符串中不是循环节的部分的长度
			 */
			int ans = (len-nnext[len]) - (len%(len-nnext[len]));//计算还需要添加的字符的数量
			printf("%d\n",ans);
		}
	}

	return 0;
}






(KMP 1.4)hdu 3746 Cyclic Nacklace(使用next数组来求循环节的长度——求一个字符串需要添加多少个字符才能使该字符串的循环节的个数>=2)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/45114169

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!