码迷,mamicode.com
首页 > 编程语言 > 详细

poj 2299 Ultra-QuickSort(树状数组 / 求逆序数)

时间:2015-04-21 22:49:23      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 46080   Accepted: 16763

Description

技术分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source






#include <iostream>
#include <stdio.h>
#include <cmath>
#include<stdlib.h>
#include <algorithm>
#include<string.h>

using namespace std;

int b[500005], c[500005];
int n;

struct node
{
    int num, id;
} a[500005];

bool cmp(node a, node b)
{
    return a.num < b.num;
}

int lowbit(int x)
{
    return x&(-x);
}

void update(int i, int x)
{
    while(i <= n)
    {
        c[i] += x;

        i = i + lowbit(i);

    }
}

int sum(int i)
{

    int sum = 0;
    while(i > 0)
    {
        sum += c[i];
        i = i - lowbit(i);

    }
    return sum;
}

int main()
{
    int i;
    long long ans;
    while(scanf("%d", &n)!=EOF)
    {
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &a[i].num);
            a[i].id = i;
        }

        sort(a+1, a+n+1, cmp);
        b[a[1].id] = 1;
        for(i = 2; i <= n; i++)
        {
            b[a[i].id] = i;
        }
        ans = 0;
        for(i = 1; i <= n; i++)
        {
            update(b[i], 1);
            ans += (sum(n)-sum(b[i]));
        }
        printf("%lld\n", ans);
    }

    return 0;
}




poj 2299 Ultra-QuickSort(树状数组 / 求逆序数)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/45174929

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!