码迷,mamicode.com
首页 > 编程语言 > 详细

POJ1094 Sorting It All Out(拓扑排序)每输入条关系判断一次

时间:2015-04-22 15:19:59      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:图论   tope   

Sorting It All Out
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 29182   Accepted: 10109

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

#include<stdio.h>
const int N = 30;

int mapt[N][N],in[N],n,m;

int tope(int tm)
{
    int path[N],k=0,l=0,uncertain=0;
    for(int i=0;i<n;i++)
    if(in[i]==0)
    path[k++]=i,in[i]=-1;

    while(l<k)
    {
        int s=path[l++];
        if(k-l!=0)
            uncertain=1;
        for(int j=0;j<n;j++)
        if(in[j]>0&&mapt[s][j])
        {
            in[j]--;
            if(in[j]==0)
                path[k++]=j,in[j]=-1;
        }
    }
    int flag=0;
    if(k!=n)//说明有环,矛盾
        printf("Inconsistency found after %d relations.\n",tm),flag=1;
    else if(uncertain==0)
    {
        printf("Sorted sequence determined after %d relations: ",tm);
        for(int i=0;i<k;i++)
            printf("%c",path[i]+'A');
        printf(".\n");
        flag=1;
    }
    else if(tm==m)//最后一次加入一个关系判断,可能的输出
        printf("Sorted sequence cannot be determined.\n"),flag=1;
    return flag;

}
int main()
{
    int in_t[N];
    char st[10];
    while(scanf("%d%d",&n,&m)>0&&n+m!=0)
    {
        for(int i=0;i<n;i++)
        {
            in_t[i]=0;
            for(int j=0;j<n;j++)
                mapt[i][j]=0;
        }
        int flag=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%s",st);
            if(flag)
                continue;
            int a=st[0]-'A';
            int b=st[2]-'A';
            if(mapt[a][b]==0)
            {
                mapt[a][b]=1; in_t[b]++;
                for(int j=0;j<n;j++)
                    in[j]=in_t[j];
                flag=tope(i);
            }
        }
    }
}


POJ1094 Sorting It All Out(拓扑排序)每输入条关系判断一次

标签:图论   tope   

原文地址:http://blog.csdn.net/u010372095/article/details/45194521

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!