码迷,mamicode.com
首页 > Web开发 > 详细

POJ 2236Wireless Network (并查集)

时间:2015-04-23 09:43:08      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

告诉几个点的坐标,O操作将电脑修复,S操作查询a,b两台电脑是否连通工作


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 222222
using namespace std;

struct Node
{
    int x,y;
    int ff;
}f[N];

int n,d;
int fa[N];

int findfa(int x)
{
    if(x==fa[x])
    return fa[x];

    return fa[x]=findfa(fa[x]);
}

double fun(int a,int b)
{
    double ans;
    ans=(f[a].x-f[b].x)*(f[a].x-f[b].x)+(f[a].y-f[b].y)*(f[a].y-f[b].y);

    return ans;
}

void uniontwo(int a,int b)
{
    int x=findfa(a);
    int y=findfa(b);
    if(x!=y)
    {
        if(x>y)
        fa[x]=y;
        else fa[y]=x;
    }
}

int main()
{
    while(~scanf("%d %d",&n,&d))
    {
        for(int i=1;i<=n;i++)
        scanf("%d %d",&f[i].x,&f[i].y);

        char ch[10];

        for(int i=0;i<=n;i++)
        {
            fa[i]=i;
            f[i].ff=0;
        }

        while(~scanf("%s",ch))
        {
            if(ch[0]=='O')
            {
                int a;
                for(int i=1;i<=n;i++)
                {
                    scanf("%d",&a);
                    f[a].ff=1;
                    if((f[i].ff && fun(i,a)<=d*d*1.0))
                    {
                        uniontwo(i,a);
                    }
                }
            }
            else
            {
                int a,b;
                scanf("%d %d",&a,&b);

                if(findfa(a)==findfa(b))
                cout<<"SUCCESS"<<endl;
                else
                cout<<"FAIL"<<endl;
            }
        }

    }
    return 0;

}



POJ 2236Wireless Network (并查集)

标签:

原文地址:http://blog.csdn.net/wust_zjx/article/details/45201651

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!