码迷,mamicode.com
首页 > 编程语言 > 详细

杭电1047(Integer Inquiry)java水过

时间:2015-04-24 10:42:56      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

点击打开杭电1047

Problem Description

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
 


 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
 


 

Output

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 


 

Sample Input

3
123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
 
0
 


 

Sample Output

370370367037037036703703703670
 
370370367037037036703703703670
 
0

 

注:格式问题!!

代码实现

import java.math.BigInteger;
import java.util.Scanner;
class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n-->0){
	   BigInteger sum=BigInteger.ZERO;
            BigInteger x;
	        while(sc.hasNextBigInteger()){
            	x=sc.nextBigInteger();
            	if(x.equals(BigInteger.valueOf(0))){
            		System.out.println(sum);
            		break;
            	}else{
            		sum=sum.add(x);
            	}
            }
            if(n!=0){
            	System.out.println();
            }
        }
    }
}


 

 

杭电1047(Integer Inquiry)java水过

标签:

原文地址:http://blog.csdn.net/u011479875/article/details/45242027

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!