码迷,mamicode.com
首页 > 编程语言 > 详细

POJ3687 Labeling Balls (拓扑排序)经典

时间:2015-04-24 19:15:12      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:tope   图论   

Labeling Balls
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11469   Accepted: 3295

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a andb indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b  N) There is a blank line before each test case.

Output

For each test case output on a single line the balls‘ weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

 

题意:n个重量为1~n的球,给定一些编号间的重量比较关系,现在给每个球编号,在符合条件的前提下使得编号小的球重量小。(先保证1号球最轻,其次2号……)

分析:拓扑排序,注意根据题的要求,要先保证1号球最轻,如果我们由轻的向重的连边,然后我们依次有小到大每次把重量分给一个入度为0的点,那么在拓扑时我们面对多个入度为0的点,我们不知道该把最轻的分给谁才能以最快的速度找到1号(使1号入度为0),并把当前最轻的分给1号。所以我们要由重的向轻的连边,然后从大到小每次把一个重量分给一个入度为0的点。这样我们就不用急于探求最小号。我们只需要一直给最大号附最大值,尽量不给小号赋值,这样自然而然就会把轻的重量留给小号。

#include<stdio.h>
#include<string.h>
const int N = 205;

int mapt[N][N],in[N],w[N],n;
int findroot()
{
    int i,j;
    for( i=n;i>0;i--)
    if(in[i]==0)
    break;
    if(i<=0)
        return 0;
    in[i]=-1;
    return i;
}
int tope()
{
    int a[N],k=0,m=n,s;
    s=findroot();
    while(s)
    {
         w[s]=m; m--;
        for(int i=1;i<=n;i++)
        if(mapt[s][i])
        {
            in[i]-=mapt[s][i];
        }
        s=findroot();
    }
    return m==0;
}
int main()
{
    int t,m,a,b;
    scanf("%d",&t);
    while(t--)
    {
        memset(mapt,0,sizeof(mapt));
        memset(in,0,sizeof(in));

        scanf("%d%d",&n,&m);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            mapt[b][a]++; in[a]++;
        }
        int flag = tope();
        if(flag==0)
        {
            printf("-1\n");
        }
        else
        {
            for(int i=1;i<=n;i++)
            {
               printf("%d",w[i]);
               if(i<n)
                    printf(" ");
            }
            printf("\n");
        }
    }
}


 

POJ3687 Labeling Balls (拓扑排序)经典

标签:tope   图论   

原文地址:http://blog.csdn.net/u010372095/article/details/45249103

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!