码迷,mamicode.com
首页 > Web开发 > 详细

POJ1962:Corporative Network(并查集)

时间:2015-04-24 22:50:15      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:poj   并查集   

Description

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input will contains only the number T of the test cases. Each test will start with the number N of enterprises (5<=N<=20000). Then some number of lines (no more than 200000) will follow with one of the commands: 
E I – asking the length of the path from the enterprise I to its serving center in the moment; 
I I J – informing that the serving center I is linked to the enterprise J. 
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

Source


题意:有n个点,一开始每个点以自己为信号终点,当输入I X Y,就连接X,Y,并且X的信号终点指向Y,E X是输出X距离信号终点的距离

思路:经典并查集,只是每个节点带权,需要更新

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define ls 2*i
#define rs 2*i+1
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,x) memset(a,x,sizeof(a))
#define w(a) while(a)
#define LL long long
const double pi = acos(-1.0);
#define Len 20005
#define mod 19999997
const int INF = 0x3f3f3f3f;

int t,n;
char str[5];
int father[Len],dis[Len];

int find(int x)
{
    if(x == father[x])
        return x;
    int fx = find(father[x]);
    dis[x] = dis[x]+dis[father[x]];
    return father[x]=fx;

}

void solve(int x,int y)
{
    int fx = find(x),fy = find(y);
    if(fx == fy)
    return;
    father[x] = x;
    dis[fx] = dis[x];
    father[x] = y;
    dis[x] = abs(x-y)%1000;
}

int main()
{
    int i,j,k,x,y;
    scanf("%d",&t);
    w(t--)
    {
        scanf("%d",&n);
        up(i,0,n)
        {
            father[i] = i;
            dis[i] = 0;
        }
        w(~scanf("%s",str))
        {
            if(str[0]=='O')
                break;
            if(str[0]=='E')
            {
                scanf("%d",&x);
                find(x);
                printf("%d\n",dis[x]);
            }
            else
            {
                scanf("%d%d",&x,&y);
                solve(x,y);
            }
        }
    }

    return 0;
}


POJ1962:Corporative Network(并查集)

标签:poj   并查集   

原文地址:http://blog.csdn.net/libin56842/article/details/45251655

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!