码迷,mamicode.com
首页 > 系统相关 > 详细

Demacia of the Ancients

时间:2015-04-26 09:28:02      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:

Demacia of the Ancients

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There is a popular multiplayer online battle arena game called Demacia of the Ancients. There are lots of professional teams playing this game. A team will be approved as Level K if there are exact K team members whose match making ranking (MMR) is strictly greater than 6000.

You are given a list of teams. Please calculate the level of each team.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 10) indicating the number of team members.

The second line contains N integers representing the MMR of each team member. All MMRs are non-negative integers less than or equal to 9999.

Output

For each test case, output the level of the given team.

Sample Input

3
5
7986 6984 6645 6200 6150
5
7401 7377 6900 6000 4300
3
800 600 200

Sample Output

5
3
0
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int T,n,count,m;
	while(cin>>T)
	{
		while(T--)
		{
			count=0;
            cin>>n;
		    while(n--)
			{
				cin>>m;
				if(m>6000)
					count++;
			}
			cout<<count<<endl;
		}
	}
	return 0;
}

Demacia of the Ancients

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/45274083

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!