码迷,mamicode.com
首页 > Web开发 > 详细

HDU ACM 1072 Nightmare

时间:2015-05-12 09:24:54      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:c++   杭电   算法   编程   acm   

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8125    Accepted Submission(s): 3896


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius‘ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius‘ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4 -1 13

 

稍微有点儿变相的搜索题。如果某条路径时间消耗到1,那么终结这条路得继续搜索。

#include<iostream>
#include<queue>
using namespace std;

int  dic[10][10];
int dir[][2]= {{0,1},{1,0},{ 0,-1},{-1,0}};
int N,M;

struct node
{
    int x,y,time,step;
};

void  bfs(int x,int y)
{
    queue<node>cnt;
    node cur,next;
    cur.x=x;
    cur.y=y;
    cur.step=0;
    cur.time=6;
    cnt.push(cur);  // 初始化第一个结点并插入队列
    int flag=1;
    while(!cnt.empty())
    {

        cur=cnt.front();
        cnt.pop();
        if(dic[cur.x][cur.y]==3)  //检查撤出的结点是否满足条件
        {
            flag=0;
            cout<<cur.step<<endl;
            break;
        }
        if(cur.time==1)
            continue;
        for(int i=0; i<4; i++)
        {
            int tx=cur.x+dir[i][0];
            int ty=cur.y+dir[i][1];
            if(tx>=0&&ty>=0&&tx<N&&ty<M&&dic[tx][ty])  //这个不用vis【】【】标记是否已经访问            {
                next.x=tx;
                next.y=ty;
                next.time=cur.time-1;
                if(dic[tx][ty]==4)  //遇到4更新结点时间属性
                {
                    next.time=6;
                    dic[tx][ty]=0;
                }
                next.step=cur.step+1;
                cnt.push(next);
            }
        }
    }
    if(flag)
        cout<<"-1"<<endl;
}

int main()
{
    int T;
    int si,sj;
    cin>>T;
    while(T--)
    {
        cin>>N>>M;
        for(int i=0; i<N; i++)
            for(int j=0; j<M; j++)
            {
                cin>>dic[i][j];
                if(dic[i][j]==2)
                {
                    si=i;
                    sj=j;
                }
            }
        bfs(si,sj);
    }
    return 0;

}
/**
234
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 3
1 4 1 0 1 1 0 1
1 0 0 1 1 0 0 1
1 1 4 1 0 1 1 1
**/


 

HDU ACM 1072 Nightmare

标签:c++   杭电   算法   编程   acm   

原文地址:http://blog.csdn.net/lsgqjh/article/details/45653701

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!