码迷,mamicode.com
首页 > Web开发 > 详细

15HD_OJ题——Rightmost Digit

时间:2015-05-25 10:09:29      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:c++   博客   iostream   namespace   

/*
 * Copyright (c) 2014, 烟台大学计算机学院
 * All rights reserved.
 * 文件名称:test.cpp
 * 作    者:李晓凯
 * 完成日期:2015年 5 月 24 日
 * 版 本 号:v1.0
 *
 * 问题描述:
 * 输入描述:
 * 程序输出:

 */

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

代码:

(1)

#include <iostream>
using namespace std;
int main()
{
    int n,T,m,a;
    cin>>T;
    while (T--)
    {
        cin>>n;
        a=n%10;
        if (a==0||a==1||a==5||a==6||a==9)
            m=a;
        else if (a==2)
        {
            if(n%4==0)
                m=6;
            else
                m=4;
        }
        else if (a==3)
        {
            if (n%4==1)
                m=3;
            else
                m=7;
        }
        else if (a==4)
        {
            m=6;
        }
        else if (a==7)
        {
            if (n%4==1)
                m=7;
            else
                m=3;
        }
        else
        {
            if (n%4==0)
                m=6;
            else
                m=4;
        }
        cout<<m<<endl;
    }
    return 0;
}


(2)
#include <iostream>
using namespace std;
int main()
{
    int T,n,i,a,k;
    cin>>T;
    while(T--)
    {
        cin>>n;
        a=n%10;
        k=1;
        for(i=0;i<=(n-1)%4;i++)
            k=k*a;
        cout<<k%10<<endl;
    }
    return 0;
}


技术分享

15HD_OJ题——Rightmost Digit

标签:c++   博客   iostream   namespace   

原文地址:http://blog.csdn.net/qq_21385857/article/details/45956377

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!