码迷,mamicode.com
首页 > 编程语言 > 详细

拓扑排序 HDU 1285 确定比赛名次

时间:2015-05-25 10:07:58      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15037    Accepted Submission(s): 6022


Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
4 3 1 2 2 3 4 3
 

Sample Output
1 2 4 3
 

Author
SmallBeer(CML)
 

Source
 
今天闲着没事 看看社么叫拓扑排序~!~挺简单的啦~ 
 
#include<iostream>
#include<queue>
#include<algorithm>
#include<string.h>
#include<stdio.h>

using namespace std;
const int M=505;
int graph[M][M];
int digree[M];

int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        memset(graph,0,sizeof(graph));
        memset(digree,0,sizeof(digree));
        for(int i=1;i<=m;i++)
        {
            int a,b;
            cin>>a>>b;
            if(graph[a][b]==0)
            {
                graph[a][b]=1;
                digree[b]++;
            }
        }
        priority_queue<int , vector<int>,greater<int> >q;

        for(int k=1;k<=n;k++)
        {
            if(!digree[k])
                q.push(k);
        }
        int ok=1;
        while(!q.empty())
        {
            int cur=q.top();
            if(ok)
                {
                    cout<<cur;ok=0;
                }
                else
                    cout<<" "<<cur;

            q.pop();
            for(int j=1;j<=n;j++)
            {
                if(graph[cur][j])
                {
                    digree[j]--;
                    if(digree[j]==0)
                        q.push(j);
                }
            }

        }
        cout<<endl;
    }
    return 0;
}

还有个和这个题基本一样的 uva 10305
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int graph[500][500];
int digree[500];

int main()

{
    int n,m;
    while(cin>>n>>m,n+m)
    {
        memset(graph,0,sizeof(graph));
        memset(digree,0,sizeof(digree));
        for(int i=1;i<=m;i++)
        {
            int a,b;
            cin>>a>>b;
            if(!graph[a][b])
           {
              graph[a][b]=1;
              digree[b]++;
           }
        }
        queue<int>q;
        for(int j=1;j<=n;j++)
        {
            if(digree[j]==0)
                q.push(j);
        }
        while(!q.empty())
        {
            int cur=q.front();
            cout<<cur<<" ";
            q.pop();
            for(int k=1;k<=n;k++)
            {
                if(graph[cur][k])
                {
                    digree[k]--;
                    if(digree[k]==0)
                        q.push(k);
                }
            }
        }
        cout<<endl;
    }
}

拓扑排序 HDU 1285 确定比赛名次

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/45955885

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!