码迷,mamicode.com
首页 > Web开发 > 详细

HDU Rightmost Digit

时间:2015-05-27 10:14:50      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

Rightmost Digit

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 87   Accepted Submission(s) : 38

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

Author

Ignatius.L
求n的n次方并输出最后一位,因为是次方所以数据会很大可以考虑用大数。但是大数很麻烦,于是找规律。通过列举数据会发现n的n方的最后一位每四次一循环。所以最多只要循环乘4次就可以得到答案。
AC代码:
#include <iostream>
using namespace std;
int main(){
    long n,m,num,p;
    cin>>num;
    while(num--){
        cin>>n;
        m = p = n % 10;
        if (n % 4 == 0) n = 4;
        else n = n % 4;
        while(--n)  p = (p * m) % 10;
        cout<<p<<endl;
    }
    return 0;
 }

运行结果:
技术分享

HDU Rightmost Digit

标签:

原文地址:http://blog.csdn.net/zp___waj/article/details/46041501

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!