码迷,mamicode.com
首页 > 移动开发 > 详细

POJ2773---Happy 2006(容斥+二分)

时间:2015-05-28 21:37:06      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:容斥   二分   

Description
Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9…are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input
The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output
Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source
POJ Monthly–2006.03.26,static

二分区间上限mid,计算[1, mid]里与n互质的数个数,多次二分以后,mid的值就是第k个和n互质的数

/*************************************************************************
    > File Name: POJ2773.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月28日 星期四 19时36分15秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

vector <int> mst;

LL calc(LL high) {
    int size = mst.size();
    LL ans = 0;
    for (int i = 1; i < (1 << size); ++i) {
        int bits = 0;
        LL P = 1;
        for (int j = 0; j < size; ++j) {
            if (i & (1 << j)) {
                ++bits;
                P *= mst[j];
            }
        }
        if (bits & 1) {
            ans += high / P;
        }
        else {
            ans -= high / P;
        }
    }
    return high - ans;
}

int main() {
    LL m, k;
    while (cin >> m >> k) {
        mst.clear();
        LL tmp = m;
        for (int i = 2; i * i <= tmp; ++i) {
            if (tmp % i == 0) {
                mst.push_back(i);
                while (tmp % i == 0) {
                    tmp /= i;
                }
            }
        }
        if (tmp > 1) {
            mst.push_back(tmp);
        }
        LL ans = -1, mid;
        LL l = 1, r = (1LL << 60);
        while (l <= r) {
            mid = (l + r) >> 1;
            LL tmp = calc(mid);
            if (tmp >= k) {
                r = mid - 1;
                ans = mid;
            }
            else {
                l = mid + 1;
            }
        }
        printf("%lld\n", ans);
    }
}

POJ2773---Happy 2006(容斥+二分)

标签:容斥   二分   

原文地址:http://blog.csdn.net/guard_mine/article/details/46127831

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!