码迷,mamicode.com
首页 > 编程语言 > 详细

YTU 2419: C语言习题 等长字符串排序

时间:2015-05-29 10:02:11      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:

2419: C语言习题 等长字符串排序

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 426  Solved: 169
[Submit][Status][Web Board]

Description

在主函数中输入n(n<=10)个等长的字符串。用另一函数对它们排序。然后在主函数输出这n个已排好序的字符串。

Input

 n和n个等长字符串

Output

 n个已排好序的字符串

Sample Input

5
abcdf
12345
ert45
fg432
erfff

Sample Output

12345
abcdf
erfff
ert45

fg432

AC代码:

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstring>
using namespace std;
void sort(char s[10][80],int n){
    char *p,temp[10];
    int i,j;
    p=temp;
    for(i=0; i<n; i++)
        for(j=0; j<n-i-1; j++)
            if(strcmp(s[j],s[j+1])>0){
                strcpy(p,s[j]);
                strcpy(s[j],s[j+1]);
                strcpy(s[j+1],p);
            }
}
int main()
{
    void sort(char [][80],int );
    int i;
    char str[10][80];
    int n;
    cin>>n;
    for (i=0; i<n; i++)
        cin>>str[i];
    sort(str,n);
    for (i=0; i<n; i++)
        cout<<str[i]<<endl;
    return 0;
}



YTU 2419: C语言习题 等长字符串排序

标签:

原文地址:http://blog.csdn.net/zp___waj/article/details/46137331

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!