码迷,mamicode.com
首页 > 编程语言 > 详细

HDU-1034-Candy Sharing Game(C++ && 简单模拟)

时间:2015-05-29 23:23:16      阅读:387      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   简单模拟   精辟   短小精悍   

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3703    Accepted Submission(s): 2311


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1035 1037 1038 1018 1028 


参照了网上的方法,不得不说,实在是精辟!精简并且容易理解,学习了!

首先解释一下题目:
一定数量的学生围成一个圈,老师站在圆的中心。每个学生最开始有偶数个糖果数。当老师吹一声哨子的时候,每一个学生同时给自己右边的邻居一半的糖果数。所有的学生,在执行这个处理之后,如果他当前的糖果数是奇数个,那么他就可以从老师手中格外获得一个糖果。这个游戏结束的条件是所有的学生都拥有相同的糖果数。写一个程序来求出游戏结束的时候老师吹口哨的次数和每个学生拥有的相同糖果数是多少。

祝室友程教主,和老赵北京蓝桥之战大获全胜!!
接下来上每日一水代码(ps.其实好像没有保证每天都有做......):

//这题是一道简单模拟,注意处理边界条件就行了!

#include<iostream>
#include<cstdio>
#define N 100
using namespace std;
int main()
{
    int s[N],n,i,k,t,p;
    while(scanf("%d",&n) == 1 && n)
    {
        for(i=0;i<n;i++)
            scanf("%d",s+i);
        for(k=1;;k++)
        {
            t=s[n-1]/2;                       //首先t存取最后一个人糖果数的一半,即处理边界条件!
            for(i=0;i<n;i++)
            {
                p=s[i]/2;                     //p存取当前糖果数的一半用来给右边的同学
                s[i]=s[i]/2+t;                //自己减一半再加上左边同学给的一半
                t=p;                          //给完一个同学当然换下一个
                if(s[i]%2!=0)                 //当前处理完如果为奇数,那就还得收老师一个
                    s[i]++;
            }
            t=s[0];
            for(i=1;i<n&&s[0]==s[i];i++);     //如果每个同学拥有的糖果数相同则游戏结束!
            if(i==n)
            {
                break;
            }
        }
        printf("%d %d\n",k,t);                //输出游戏次数和每个人最终的糖果数
    }
    return 0;
}


 

HDU-1034-Candy Sharing Game(C++ && 简单模拟)

标签:acm   c++   简单模拟   精辟   短小精悍   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46237975

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!