标签:c++ cpp 数据 编程 类
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
Sample Output
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
代码
#include <iostream>
using namespace std;
int main()
{
long n,m,num,p;
cin>>num;
while(num--){
cin>>n;
m = p = n % 10;
if (n % 4 == 0) n = 4;
else n = n % 4;
while(--n) p = (p * m) % 10;
cout<<p<<endl;
}
return 0;
}
主要还是找规律一些项目——Rightmost Digit
标签:c++ cpp 数据 编程 类
原文地址:http://blog.csdn.net/blue_skyrim/article/details/46275903