码迷,mamicode.com
首页 > Web开发 > 详细

一些项目——Rightmost Digit

时间:2015-05-30 18:19:19      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:c++   cpp   数据   编程      

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.



代码

#include <iostream>
using namespace std;
int main()
{
    long n,m,num,p;
    cin>>num;
    while(num--){
        cin>>n;
        m = p = n % 10;
        if (n % 4 == 0) n = 4; 
        else n = n % 4;
        while(--n)  p = (p * m) % 10;
        cout<<p<<endl;
    }
    return 0;
}

主要还是找规律

一些项目——Rightmost Digit

标签:c++   cpp   数据   编程      

原文地址:http://blog.csdn.net/blue_skyrim/article/details/46275903

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!