码迷,mamicode.com
首页 > 移动开发 > 详细

HDU1028Ignatius and the Princess III(一个数有多少种组合方式,DP)与放n个苹果在m个盘子有多少生种组合一样(两种方法解)

时间:2015-06-03 15:50:12      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:dp

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15210    Accepted Submission(s): 10724


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L
 

解题:把n看作是苹果的数量,每个位置看作是盘子,那么最多有n个盘子。第m个盘子最多放n/m个,也就是每个盘放苹果数量服从的原则是:非递增式放数量。

#include<stdio.h>
#include<string.h>
const int N = 125;
#define LL __int64

LL dp[N][N][N],sum[N][N];
int main(){
    memset(dp,0,sizeof(dp));
    memset(sum,0,sizeof(sum));
    for(int i=1;i<=124;i++)
        dp[i][1][i]=1;
    sum[1][1]=1;
    for(int i=2;i<=124;i++)//苹果数
    for(int j=2;j<=i;j++){  //盘子数
        for(int k=0;k<=i/j;k++){ //最后一个盘放的数量
            dp[i][j][k]=0;
            for(int tk=k;tk<=(i-k)/(j-1);tk++)//倒数第二个盘放的数量
            dp[i][j][k]+=dp[i-k][j-1][tk];
            sum[i][j]+=dp[i][j][k];
        }
    }
    int n;
    while(scanf("%d",&n)>0)
        printf("%I64d\n",sum[n][n]);
}

方法二:方法出处

#include<stdio.h>
#include<string.h>
const int N = 125;
#define LL __int64

LL sum[N][N];
int main(){
    
    memset(sum,0,sizeof(sum));
    for(int i=1;i<=124;i++)
        sum[1][i]=sum[i][1]=1;

    for(int i=2;i<=120;i++)
    for(int j=2;j<=120;j++){  
       
        if(j>i)sum[i][j]=sum[i][i];
        else if(i==j)sum[i][j]=sum[i][j-1]+1;
        else sum[i][j]=sum[i][j-1]+sum[i-j][j];
    }
    int n;
    while(scanf("%d",&n)>0)
        printf("%I64d\n",sum[n][n]);
}


HDU1028Ignatius and the Princess III(一个数有多少种组合方式,DP)与放n个苹果在m个盘子有多少生种组合一样(两种方法解)

标签:dp

原文地址:http://blog.csdn.net/u010372095/article/details/46345069

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!