码迷,mamicode.com
首页 > 编程语言 > 详细

Matrix+POJ+二维树状数组初步

时间:2015-06-04 22:41:15      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

                                                                                                                                               Matrix
   

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

 
# include<iostream>
# include<cstdio>
# include<cstring>
# include<string>
# include<set>
# include<map>
# include<sstream>
using namespace std;
const int maxn=1000+5;
int tree[maxn][maxn];
char a[10];
int n;
int lowbit(int x)
{
    return x&-x;
}
int getsum(int x,int y)
{
    int s=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
           s+=tree[i][j];
           if(s%2==0)  return 0;
            else
                return 1;
}
void update(int x,int y)
{
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            tree[i][j]^=1;
}
int main()
{
    /*#ifndef ONLINE_JUDGE
       freopen("in.cpp","r",stdin);
       freopen("out.cpp","w",stdout);
    #endif*/
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
               tree[i][j]=0;
        while(m--)
        {
            int x1,y1,x2,y2;
           scanf("%s%d%d",&a[0],&x1,&y1);
           if(a[0]=='C')
           {
               scanf("%d%d",&x2,&y2);
               update(x2+1,y2+1);
               update(x2+1,y1);
               update(x1,y2+1);
               update(x1,y1);
           }
           else if(a[0]=='Q')
           {
               printf("%d\n",getsum(x1,y1));
           }
        }
        cout<<endl;
    }

    return 0;
}

Matrix+POJ+二维树状数组初步

标签:

原文地址:http://www.cnblogs.com/hrhguanli/p/4553102.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!