码迷,mamicode.com
首页 > 编程语言 > 详细

HDU-1040-As Easy As A+B(诚如题目所说和A+B一样简单-插入排序水过)

时间:2015-06-09 13:47:43      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:插入排序   每日一水   acm   c++   不知道说什么   

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45268    Accepted Submission(s): 19340


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
 

Author
lcy
 

Recommend
We have carefully selected several similar problems for you:  1096 1090 1091 1021 1093 

让你见识一下什么叫大水神,插入排序水过......(前几天看算法导论,特么看了半天就看懂一个插入!!)

#include<iostream>
#include<cstdio>
using namespace std;
int a[10000];
int main()
{
    int t,i,j,n,target;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=1;i<n;i++)
        {
            j=i;
            target=a[i];
            while(j>0&&target<a[j-1])
            {
                a[j]=a[j-1];
                j--;
            }
            a[j]=target;
        }
        for(i=0;i<n;i++)
        {
            if(i!=n-1)
                printf("%d ",a[i]);
            else
                printf("%d\n",a[i]);
        }
    }
    return 0;
}






 

HDU-1040-As Easy As A+B(诚如题目所说和A+B一样简单-插入排序水过)

标签:插入排序   每日一水   acm   c++   不知道说什么   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46425745

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!