码迷,mamicode.com
首页 > 编程语言 > 详细

poj1797 Heavy Transportation (Kruskal 算法)

时间:2015-06-09 19:09:48      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

                                                               Heavy Transportation
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 22796   Accepted: 6053

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo‘s place) to crossing n (the customer‘s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

水水水、、、
恩,就是求能从1-n的路径的最小边的最大值嘛,,,
嘛嘛,,,虽然感觉用这个算法解决的问题,差不多就是用并查集就能够解决oooo。。。
不过这个解法确实很巧妙诶,,,

#include<stdio.h>
#include<algorithm>
using namespace std;

struct Edge{
    int u,v,w;
};
Edge e[1000005];
int p[1005];
int r[1005];

bool cmp(Edge e1,Edge e2){
    return e1.w>e2.w;
}

//并查集部分
int find(int u){
    if(u!=p[u]){
        p[u]=find(p[u]);
    }
    return p[u];
}
void join(int u,int v){
    int a=find(u);
    int b=find(b);
    if(a==b){
        return ;
    }
    if(r[a]>r[b]){
        p[b]=a;
    }
    else if(r[a]<r[b]){
        p[a]=b;
    }
    else{
        p[a]=b;
        r[b]++;
    }
}
void init(int n){
    for(int i=1;i<=n;i++){
        p[i]=i;
        r[i]=i;
    }
}

int main(){
    int t;
    scanf("%d",&t);
    int casee=1;
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
        }
        sort(e,e+n,cmp);
        int res;
        for(int i=0;i<m;i++){
            if(find[1]==find[n]){
                break;
            }//判断此时1-n的路是否已经连通
            int u=e[i].u;
            int v=e[i].v;
            if(find[u]!=find[v]){
                res=e[i].w;
                join(u,v);
            }//如果现在这条边的两个点不在同一个集合中,才加到并查集里面去,否则就不
        }//因为已经按权值由大到小排好序了嘛,现在的res值就一定是始它能连通的时候的最大权值了。。。
        printf("Scenario #%d:\n%d\n\n",casee,res);
        casee++;
    }
    return 0;
}


poj1797 Heavy Transportation (Kruskal 算法)

标签:

原文地址:http://www.cnblogs.com/pylbyurway/p/4563905.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!