码迷,mamicode.com
首页 > 编程语言 > 详细

HDU-1042-N!(Java大法好 && HDU大数水题)

时间:2015-06-10 12:25:49      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:acm   java   大数   hdu   水题   

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 64256    Accepted Submission(s): 18286


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6
 

Author
JGShining(极光炫影)
 

Recommend
We have carefully selected several similar problems for you:  1715 1047 1063 1753 1316 


Java大法好,退C保平安.......开玩笑的,Java和C各有各的优劣势,缺一不可!我不会大数模版,就用BigInteger了,HDU大数水题不解释!

import java.io.*;
import java.math.BigInteger;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		Scanner input = new Scanner(System.in);
		while(input.hasNext())
		{
			int n = input.nextInt();
			BigInteger p = BigInteger.ONE;
			for(int i=1;i<=n;i++)
			{
				p=p.multiply(BigInteger.valueOf(i));
			}
			System.out.println(p);
		}
	}

}



 

HDU-1042-N!(Java大法好 && HDU大数水题)

标签:acm   java   大数   hdu   水题   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46438985

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!