码迷,mamicode.com
首页 > 编程语言 > 详细

HDU-1050-Moving Tables(C++ && 贪心初步)

时间:2015-06-20 09:16:52      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:acm   不知道说什么   c++   hdu   水题   

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23147    Accepted Submission(s): 7779


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

技术分享


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

技术分享


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
10 20 30
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1051 1009 1052 1789 1045 

5天没水了,整个人都水的不行,看这个英文题也是看了老半天,这让我想起上个星期的6级估计也是跪了!草!言归正传!

首先解释一下题目的大意:
在走廊的北边和南边各有200个房间,最近公司做出一个计划打算改革这个体系。这个改革就包括在这些房间之间移动很多桌子(我开头把table理解成表格,整个人都傻了!)因为走廊很狭窄,然后所有的桌子都很大。一次只有一个桌子能够通过这个走廊。这个计划需求就是要这个移桌子的过程更加有效率。经理弄清了这个计划定义:1.把桌子从一个房间移动到另一个房间的时间在十分钟内。2.当把一个桌子从i房间移动到j房间,这个走廊的i部分到j部分就是被使用过的。所以,在这个10分钟内,在这两个房间之间的走廊部分是不能再同时被使用的。为了弄清楚经理的需求,下面的插画,就是来举出的几个可能发生与不可能发生的例子!

这题考的似乎是贪心算法,但是我参考了一种更简单的思路,贯彻本题的一句话,最大的交叉次数就是需要搬运的回合数!只要根据这句话,这个题目就可以水过了!(感谢wei_xiaohui同学的思路!)


假设从1到400(下标从1开始)的走廊是一条线段,每次搬一张桌子,假设从15号房间搬到25号房间,则线段15->25就重复了一次。然后另外再去搬一张桌子,假设这回从20号房间搬到30号房间,则线段20->30就重复了一次,相同的线段:20->25就重复了两次,问题转化为求最大重复次数。

那就好办了,一个205大小的数组表示走廊位置(200个走廊位置),初始化为0,如果15->25重复了一次,则对15,16,17,18,19,20的走廊位置都加上1,第二次线段20->30又重复了,则又对20....30的位置加1。全部完成后,找出走廊最大值的位置,乘以10分钟,就是所用时间!

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[205];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        int start,finish;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&start,&finish);
            if(start>finish)
            {
                swap(start,finish);
            }
            start = (start+1)/2;
            finish = (finish+1)/2;
            for(int j=start;j<=finish;j++)
            {
                a[j]++;
            }
        }
        int MAX = 0;
        for(int i=0;i<205;i++)
        {
            if(a[i]>MAX)
            {
                MAX=a[i];
            }
        }
        printf("%d\n",MAX*10);
    }
    return 0;
}




 

HDU-1050-Moving Tables(C++ && 贪心初步)

标签:acm   不知道说什么   c++   hdu   水题   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46564797

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!