码迷,mamicode.com
首页 > 编程语言 > 详细

第十五周oj刷题——Problem B: 矩形类定义【C++】

时间:2015-06-21 14:35:29      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:c++   iostream   namespace   class   指针   

Description
定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。

Input
四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。

Output
输出一共有3行(请参考提示(hint)中的main函数):
第一行:由输入的坐标确定的矩形对象p1的面积
第二行:由对象复制得到的矩形对象p2的面积
第三行:直接初始化得到的矩形对象p3的面积

Sample Input
3.7 0.4 6.5 4.9
Sample Output
12.6
12.6
10

/* All rights reserved.
 * 文件名称:test.cpp
 * 作者:陈丹妮
 * 完成日期:2015年 6 月 21 日
 * 版 本 号:v1.0
 */
#include <iostream>
#include <cmath>
using namespace std;
class Rectangle
{
private:
    double x1;
    double y1;
    double x2;
    double y2;
public:
    Rectangle(double a1=1,double b1=1,double a2=6,double b2=3):x1(a1),y1(b1),x2(a2),y2(b2) {}
    Rectangle(Rectangle &p);
    void input();
    void output();
};
void Rectangle::input()
{
    cin>>x1>>y1>>x2>>y2;
}
void Rectangle::output()
{
    double s;
    s=abs(x2-x1)*abs(y2-y1);
    cout<<s<<endl;
}
Rectangle::Rectangle(Rectangle &p)
{
    x1=p.x1;
    y1=p.y1;
    x2=p.x2;
    y2=p.y2;
}
int main()
{
    Rectangle p1;
    p1.input();
    p1.output();
    Rectangle p2(p1);
    p2.output();
    Rectangle p3(1,1,6,3);
    p3.output();
    return 0;
}

技术分享

心得体会:这个还是比较简单,继续努力,刷题刷题!!!

第十五周oj刷题——Problem B: 矩形类定义【C++】

标签:c++   iostream   namespace   class   指针   

原文地址:http://blog.csdn.net/nufangdongde/article/details/46581369

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!