码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 3584 Cube(三维树状数组)

时间:2015-07-13 14:11:50      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:hdu 3584 cube   三维树状数组   

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1660    Accepted Submission(s): 865


Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 

Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
 

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 

Sample Input
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 

Sample Output
1 0 1
 

Author
alpc32
 

Source
 


Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:  3450 1541 1892 2492 3743 
 

题意:N*N*N的立方体,元素为0或1(初始为0)。1操作将(x1,y1,z1)到(x2,y2,z2)之间的元素取反;0操作是询问(x,y,z)为0或1。

题解:三维树状数组,原理跟一维,二维一样,可以参考http://blog.csdn.net/acm_baihuzi/article/details/46819049

#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstdio>
#define N 110

using namespace std;

int n,q;
int bit[N][N][N];
int getsum(int a,int b,int c) {
    int sum=0;
    for(int i=a; i>0; i-=i&-i) {
        for(int j=b; j>0; j-=j&-j) {
            for(int k=c; k>0; k-=k&-k) {
                sum+=bit[i][j][k];
            }
        }
    }
    return sum;
}

void add(int a,int b,int c) {
    for(int i=a; i<=n; i+=i&-i) {
        for(int j=b; j<=n; j+=j&-j) {
            for(int k=c; k<=n; k+=k&-k) {
                bit[i][j][k]^=1;
            }
        }
    }
}

int main() {
    //freopen("test.in","r",stdin);
    while(cin>>n>>q) {
        memset(bit,0,sizeof bit);
        int op,x2,y2,z2,x1,y1,z1;
        while(q--) {
            scanf("%d%d%d%d",&op,&x1,&y1,&z1);
            if(op==0) {
                printf("%d\n",getsum(x1,y1,z1)%2);
                continue;
            }
            scanf("%d%d%d",&x2,&y2,&z2);
            add(x1,y1,z1);
            add(x1,y1,z2+1);
            add(x1,y2+1,z1);
            add(x1,y2+1,z2+1);
            add(x2+1,y1,z1);
            add(x2+1,y1,z2+1);
            add(x2+1,y2+1,z1);
            add(x2+1,y2+1,z2+1);
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 3584 Cube(三维树状数组)

标签:hdu 3584 cube   三维树状数组   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/46860955

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!