码迷,mamicode.com
首页 > 编程语言 > 详细

POJ题目2585Window Pains(拓扑排序)

时间:2015-07-20 23:39:20      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:

Window Pains
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1731   Accepted: 863

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux‘s windows would be represented by the following 2 x 2 windows: 
1 1 . .
1 1 . .
. . . .
. . . .
. 2 2 .
. 2 2 .
. . . .
. . . .
. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .
. . . .
. 5 5 .
. 5 5 .
. . . .
. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .
. . . .
. . . .
. 8 8 .
. 8 8 .
. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ?
If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?
. . . and so on . . . 
Unfortunately, Boudreaux‘s computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line: 
    START 

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux‘s screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux‘s screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

Source

South Central USA 2003

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
int a[4][4][4]={{{1},{1,2},{2,3},{3}},{{1,4},{1,2,4,5},{2,3,5,6},{3,6}},{{4,7},{4,5,7,8},{5,6,8,9},{6,9}},{{7},{7,8},{8,9},{9}}};
int mapp[22][22],dig[10],map[22][22];
int topu()
{
	int i,num=0;
	queue<int>q;
	for(i=1;i<10;i++)
	{
		if(dig[i]==0)
		{
			q.push(i);
			dig[i]--;
		}
	}
	while(!q.empty())
	{
		int u=q.front();
		num++;
		q.pop();
		int flag=0;
		for(i=1;i<10;i++)
		{
			if(map[u][i])
			{
				dig[i]--;
			}
			if(dig[i]==0)
			{
				q.push(i);
				dig[i]--;
			}
			
		}
	}
	if(num==9)
		return 1;
	return 0;
}
int main()
{
	char str[20];
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp(str,"ENDOFINPUT")==0)
			break;
		int i,j,k;
		memset(dig,0,sizeof(dig));
		memset(map,0,sizeof(map));
		for(i=0;i<4;i++)
		{
			for(j=0;j<4;j++)
			{
				scanf("%d",&mapp[i][j]);
				for(k=0;k<4;k++)
				{
					if(a[i][j][k]==0)
						break;
			//		printf("%d ",a[i][j][k]);
					if(a[i][j][k]!=mapp[i][j]&&map[mapp[i][j]][a[i][j][k]]==0)
					{
						map[mapp[i][j]][a[i][j][k]]=1;
						dig[a[i][j][k]]++;
					}
				}
			//	printf("\n");
			}
		}
		scanf("%s",str);
	/*	for(i=1;i<=9;i++)
		{
			for(j=1;j<=9;j++)
			{
				printf("%d ",map[i][j]);
			}
			printf("\n");
		}
		for(i=1;i<=9;i++)
			printf("%d ",dig[i]);*/
		if(topu())
		{
			printf("THESE WINDOWS ARE CLEAN\n");
		}
		else
			printf("THESE WINDOWS ARE BROKEN\n");
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ题目2585Window Pains(拓扑排序)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/46973827

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!