码迷,mamicode.com
首页 > Web开发 > 详细

poj 1258 Agri-Net(Prim)(基础)

时间:2015-07-20 23:41:10      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:poj   prim   

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44487   Accepted: 18173

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题意:
有n个农场,已知这n个农场都互相相通,有一定的距离,现在每个农场需要装光纤,问怎么安装光纤能将所有农场都连通起来,并且要使光纤距离最小,输出安装光纤的总距离。

思路:
最小生成树,给出的二维矩阵代表他们的距离,prim算法求解即可。
代码:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define maxn 110
#define inf 1<<29

int Map[maxn][maxn],vis[maxn],low[maxn];
int n;
//第一种
void prim()
{
    int Min,pos,sum=0;
    for(int i=1;i<=n;i++)
    {
        low[i]=Map[1][i];
        vis[i]=0;
    }
    for(int i=1;i<=n;i++)
    {
        Min=inf;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && low[j]<Min)
            {
                pos=j;
                Min=low[j];
            }
        }
        vis[pos]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && low[j]>Map[pos][j])
                low[j]=Map[pos][j];
        }
    }
    for(int i=1;i<=n;i++)
        sum+=low[i];
    printf("%d\n",sum);
}
/*第二种
void prim()
{
    int Min,pos,sum=0;
    memset(vis,0,sizeof(vis));
    vis[1]=1,pos=1;
    for(int i=1;i<=n;i++)
    {
        if(i!=pos)
            low[i]=Map[pos][i];
    }
    for(int i=1;i<n;i++)
    {
        Min=inf;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && low[j]<Min)
            {
                Min=low[j];
                pos=j;
            }
        }
        sum+=Min;
        vis[pos]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && low[j]>Map[pos][j])
                low[j]=Map[pos][j];
        }
    }
    printf("%d\n",sum);
}
*/
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&Map[i][j]);
        prim();
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1258 Agri-Net(Prim)(基础)

标签:poj   prim   

原文地址:http://blog.csdn.net/kaisa158/article/details/46973409

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!