码迷,mamicode.com
首页 > Windows程序 > 详细

hdoj 1509 Windows Message Queue(优先队列)

时间:2015-07-24 20:46:27      阅读:285      评论:0      收藏:0      [点我收藏+]

标签:c   acm   算法   杭电   数据结构   

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4309 Accepted Submission(s): 1701


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input
There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.

Sample Input
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET

Sample Output
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!

Author
ZHOU, Ran

Source
<span style="font-size:14px;">#include<cstdio>
#include<cstring>
#include<queue>
#include<cstdlib>
#include<algorithm>
using namespace std;
<strong><span style="color:#ff0000;">struct node
{
 char name[20];
 int level;//优先权 
 int id;//进队顺序 
 int par;//作业的参数 
 friend  bool operator<(node a,node b)
 {
   if(a.level!=b.level)//先输出优先级高的(即level小的) 
     return b.level<a.level;
   else                //优先级相同时,根据进队顺序输出 
      return b.id<a.id;
 }
};</span></strong>
int main()
{
   char opr[10];
   int count=0;	
   node mesg;
   priority_queue<node>q;
   while(~scanf("%s",opr))
   {
   
	if(strcmp(opr,"PUT")==0)
   	 {
   	 	scanf("%s%d%d",mesg.name,&mesg.par,&mesg.level);
   	 	mesg.id=count++;//先进来的顺序小 
   	 	q.push(mesg);
	 }
	 else if(strcmp(opr,"GET")==0)
	 {
	 	if(!q.empty())
	 	{
	 	   node msg=q.top();
	 	   q.pop();
		   printf("%s %d\n",msg.name,msg.par);
		} 
	 	else
	 	 printf("EMPTY QUEUE!\n");
	 }
   }
   return 0;
}</span>



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 1509 Windows Message Queue(优先队列)

标签:c   acm   算法   杭电   数据结构   

原文地址:http://blog.csdn.net/lh__huahuan/article/details/47046083

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!