标签:acm 算法 数据结构 杭电 计算机
Legal or Not
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5737 Accepted Submission(s): 2651
点击打开链接
Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When
someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are
too many masters and too many prentices, how can we know whether it is legal or not?
We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian
is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.
Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which
means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
Sample Output
题意 :一个可以有多个师傅,或者多个徒弟。 师傅的师傅的一样是自己的师傅,徒弟的徒弟的,一样是自己的徒弟。 但是一个人不能即是一个人的师傅,也是这个人的徒弟。
问 如果存在这种混乱关系的,就输出NO, 否则输出 YES.
策略:
如果本人是师傅就继续让他做比他等级低的师傅,否则就做比他等级高的师傅,由此可以想到拓扑排序,考虑之间的关系
<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<queue>
#include<cstdlib>
#include<algorithm>
using namespace std;
priority_queue<int,vector<int>,greater<int> >q;
int degree[110];
int map[110][110];
int n,m;
int topsort()
{
int i;
for(i=0;i<n;i++)
if(degree[i]==0)
q.push(i);
int k=0;
while(!q.empty())
{
int v=q.top();
q.pop();
for(i=0;i<n;i++)
{
if(map[v][i]==0)
continue;
degree[i]--;
if(degree[i]==0)
q.push(i);
}
}
for(i=0;i<n;i++)
if(degree[i]>0)
return 0;
return 1;
}
int main()
{
while(scanf("%d%d",&n,&m)&&(n||m))
{
memset(map,0,sizeof(map));
memset(degree,0,sizeof(degree));
for(int i=0;i<m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
if(map[x][y]==0)
{
map[x][y]=1;
degree[y]++;
}
}
if(topsort())
printf("YES\n");
else
printf("NO\n");
}
return 0;
} </span>
版权声明:本文为博主原创文章,未经博主允许不得转载。
hdoj 3342 Legal or Not(拓扑排序)
标签:acm 算法 数据结构 杭电 计算机
原文地址:http://blog.csdn.net/lh__huahuan/article/details/47082377