码迷,mamicode.com
首页 > Web开发 > 详细

poj 2349 Arctic Network

时间:2015-07-28 10:25:18      阅读:394      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=2349

Arctic Network
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12544   Accepted: 4097

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#define INF 0x3f3f3f3f
#define max(a, b)(a > b ? a : b)
#define min(a, b)(a < b ? a : b)
#define N 510

using namespace std;

struct st
{
    int x, y;
} node[N];

double G[N][N], dist[N];
int n;
bool vis[N];

void Init()
{
    int i, j;
    memset(vis, false, sizeof(vis));
    for(i = 0 ; i < n ; i++)
    {
        for(j = 0 ; j < n ; j++)
        {
            if(i == j)
                G[i][j] = 0;
            G[i][j] = G[j][i] = INF;
        }
    }
}

void prim(int s)
{
    int index, i, j;
    double Min;
    for(i = 0; i < n ; i++)
        dist[i] = G[s][i];
    vis[s] = true;
    for(i = 1 ; i < n ; i++)
    {
        Min = INF;
        for(j = 0 ; j < n ; j++)
        {
            if(!vis[j] && dist[j] < Min)
            {
                Min = dist[j];
                index = j;
            }
        }
        vis[index] = true;
        for(j = 0 ; j < n ; j++)
        {
            if(!vis[j] && dist[j] > G[index][j])
                dist[j] = G[index][j];
        }
    }
}

int cmp(const void *a, const void *b)
{
    return *(double *)a > *(double *)b ? 1 : -1;
}//double类型快排,因为这wa了很多次

int main()
{
    int i, j, s, t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &s, &n);
        Init();
        for(i = 0 ; i < n ; i++)
            scanf("%d%d", &node[i].x, &node[i].y);
        for(i = 0 ; i < n ; i++)
        {
            for(j = 0 ; j < n ; j++)
            {
                G[i][j] = G[j][i] = sqrt((node[i].x - node[j].x) * (node[i].x - node[j].x) + (node[i].y - node[j].y) * (node[i].y - node[j].y));
            }
        }
        prim(0);
        qsort(dist, n, sizeof(dist[0]), cmp);
        printf("%.2f\n", dist[n - s]);
    }
    return 0;
}

 

poj 2349 Arctic Network

标签:

原文地址:http://www.cnblogs.com/qq2424260747/p/4681874.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!