码迷,mamicode.com
首页 > Windows程序 > 详细

hdu 杭电1509 Windows Message Queue

时间:2015-07-28 10:44:58      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.
 

Sample Input
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 



#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>

using namespace std;
struct message
{
	char name[110];
	int pri;
	int data;
	int num;
	friend bool operator < (message a,message b)//重新定义队列顺序 
	{
		if(a.pri==b.pri) return a.num>b.num;
		return a.pri>b.pri;
	}
};
priority_queue<message>q;//定义优先队列 
message temp;
int main()
{
	char s[110];
	int i=0;
	while(~scanf("%s",s))
	{
		if(strcmp(s,"GET")==0)
		{
			if(!q.empty())
			{
				printf("%s %d\n",q.top().name,q.top().data);
				q.pop();
			}
			else
			{
				printf("EMPTY QUEUE!\n");
			}
		}
		else
		{
			scanf("%s %d %d",temp.name,&temp.data,&temp.pri);
			temp.num=++i;//把每个数据的序号保存,数据小的先输出 
			q.push(temp);
		}
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 杭电1509 Windows Message Queue

标签:

原文地址:http://blog.csdn.net/yuzhiwei1995/article/details/47101545

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!