码迷,mamicode.com
首页 > Windows程序 > 详细

Windows Message Queue

时间:2015-07-28 21:04:57      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4440    Accepted Submission(s): 1766


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.
 

Sample Input
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!

刚开始没有考虑如果优先级相等,要按输入的先后顺序输出这种情况;

#include<stdio.h>
#include<queue>
using namespace std;
struct stu
{
	char name[20];
	int num;
	int number;
	int id;
	friend bool operator<(stu x,stu y)
	{
		if(x.number==y.number)
			return x.id>y.id;
		return x.number>y.number;
	}
};
int main()
{
	char a[50];
	struct stu b;
	int c=0; 
	//priority_queue<int,vector<int>,greater<int> >q;
	priority_queue<stu> q;
	while(scanf("%s",a)!=EOF){
		if(a[0]=='G')
		{
			if(q.empty())
			{
				printf("EMPTY QUEUE!\n");
			}
			else {
				b=q.top();
				printf("%s %d\n",b.name,b.num);
				q.pop();
			}
		}
		else{
			scanf("%s%d%d",b.name,&b.num,&b.number);	//	q.push(b.number);//b.number=c;
		b.id=++c; //标记输入的顺序
		q.push(b);
		}
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Windows Message Queue

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47110961

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!