码迷,mamicode.com
首页 > 编程语言 > 详细

HDOJ Color the ball 1556【树状数组】

时间:2015-07-29 21:20:12      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12218    Accepted Submission(s): 6101


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
1 1 1 3 2 1
 

Author
8600
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:  1542 1394 1698 1255 2795 
 

树状数组 区间更新 单点求值

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 100000+100

using namespace std;

int bit[maxn];

int lowbit(int x)
{
	return x&(-x);
}

void add(int x,int y)
{
	while(x<maxn){
		bit[x]+=y;
		x+=lowbit(x);
	}
}

int query(int x)
{
	int s=0;
	while(x>0){
		s+=bit[x];
		x-=lowbit(x);
	}
	return s;
}

int main()
{
    int n;
    while(scanf("%d",&n),n){
		memset(bit,0,sizeof(bit));
		int a,b;
		for(int i=0;i<n;i++){
			scanf("%d%d",&a,&b);
			add(a,1);
			add(b+1,-1);
		}
		for(int i=1;i<n;i++){
			printf("%d ",query(i));
		}
		printf("%d\n",query(n));
    }
    return 0;
}



版权声明:本文为博主原创文章,转载请注明出处。

HDOJ Color the ball 1556【树状数组】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47133563

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!