码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 2642(树状数组模板二维)

时间:2015-08-03 19:10:45      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 1350    Accepted Submission(s): 554

Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where ‘B‘ represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the ‘D‘ in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.
There is only one case.
 
Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 
Output
For each query,output the number of bright stars in one line.
 
Sample Input
5
B 581 145
B 581 145
Q 0 600 0 200
D 581 145
Q 0 600 0 200
 
Sample Output
1

0

//标准的模板题二维

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

const int N=1010;

int c[N][N];
bool vis[N][N];

int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int y,int val)
{
    int i=y;
    while(x<=N)
    {
        y=i;
        while(y<=N)
        {
            c[x][y]+=val;
            y+=lowbit(y);
        }
        x+=lowbit(x);
    }
}

int sum(int x,int y)
{
    int i,sum=0;
    i=y;
    while(x)
    {
        y=i;
        while(y)
        {
            sum+=c[x][y];
            y-=lowbit(y);
        }
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    int n,x1,x2,y1,y2;
    scanf("%d",&n);
    memset(c,0,sizeof(c));
    memset(vis,0,sizeof(vis));
    while(n--)
    {
        getchar();
        char c;
        scanf("%c ",&c);
        if(c=='Q')
        {
            scanf("%d%d%d%d",&x1,&x2,&y1,&y2);
            x1++,x2++,y1++,y2++;
            if(x1>x2)swap(x1,x2);
            if(y1>y2)swap(y1,y2);
            printf("%d\n",(sum(x2,y2)+sum(x1-1,y1-1)-sum(x1-1,y2)-sum(x2,y1-1)));  
        }
        else if(c=='B')
        {
            scanf("%d%d",&x1,&y1);
            if(vis[x1+1][y1+1]==1)
                continue;
            else
                add(x1+1,y1+1,1);
            vis[x1+1][y1+1]=1;
        }
        else if(c=='D')
        {
            scanf("%d%d",&x1,&y1);
            if(vis[x1+1][y1+1]==0)
                continue;
            else
                add(x1+1,y1+1,-1);
            vis[x1+1][y1+1]=0;
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 2642(树状数组模板二维)

标签:

原文地址:http://blog.csdn.net/a73265/article/details/47260001

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!