码迷,mamicode.com
首页 > Web开发 > 详细

hdoj 1061 Rightmost Digit【快速幂求模】

时间:2015-08-04 13:07:49      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39554    Accepted Submission(s): 14930


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the rightmost digit of N^N.
 

 

Sample Input
2
3
4
 

 

Sample Output
7
6
#include<stdio.h>
#include<string.h>
int f(int x)
{
	int ans=1;
	int y=x;
	x=x%10;
	while(y)
	{
		if(y&1)
		    ans=(ans*x)%10;
		y/=2;
		x=(x*x)%10;
	}
	return ans;
}
int main()
{
	int n,m,j,i,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		printf("%d\n",f(n));
	}
	return 0;
}

  

hdoj 1061 Rightmost Digit【快速幂求模】

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4701470.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!