码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 5351 MZL's Border(java 找规律)

时间:2015-08-04 21:02:41      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:hdu   java   数学   多校2015   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5351


Problem Description
As is known to all, MZL is an extraordinarily lovely girl. One day, MZL was playing with her favorite data structure, strings.

MZL is really like Fibonacci Sequence, so she defines Fibonacci Strings in the similar way. The definition of Fibonacci Strings is given below.
  
  1) fib1=b
  
  2) fib2=a
  
  3) fibi=fibi?1fibi?2, i>2
  
For instance, fib3=ab, fib4=aba, fib5=abaab.

Assume that a string s whose length is n is s1s2s3...sn. Then sisi+1si+2si+3...sj is called as a substring of s, which is written as s[i:j].

Assume that i<n. If s[1:i]=s[n?i+1:n], then s[1:i] is called as a Border of s. In Borders of s, the longest Border is called as s‘ LBorder. Moreover, s[1:i]‘s LBorder is called as LBorderi.

Now you are given 2 numbers n and m. MZL wonders what LBorderm of fibn is. For the number can be very big, you should just output the number modulo 258280327(=2×317+1).

Note that 1T100, 1n103, 1m|fibn|.
 

Input
The first line of the input is a number T, which means the number of test cases.

Then for the following T lines, each has two positive integers n and m, whose meanings are described in the description.
 

Output
The output consists of T lines. Each has one number, meaning fibn‘s LBorderm modulo 258280327(=2×317+1).
 

Sample Input
2 4 3 5 5
 

Sample Output
1 2
 

Source


PS:

技术分享

代码如下:

import java.util.Scanner;
import java.math.BigInteger;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int t = sc.nextInt();
		BigInteger[] a = new BigInteger[1017];
		a[1] = BigInteger.valueOf(1);
		a[2] = BigInteger.valueOf(2);
		for (int i = 3; i < 1017; i++) {
			a[i] = a[i - 1].add(a[i - 2]);
		}
		while (t > 0) {
			t--;
			int n = sc.nextInt();
			BigInteger m = sc.nextBigInteger();

			for (int i = 2; i < 1050; ++i) {
				BigInteger tt = m.add(BigInteger.valueOf(1));
				if (m.compareTo(a[i]) < 0 && m.compareTo(a[i - 1]) >= 0) {
					BigInteger ans = m.subtract(a[i - 2]).mod(
							BigInteger.valueOf(258280327));
					System.out.println(ans);
					break;
				}
			}
		}
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5351 MZL's Border(java 找规律)

标签:hdu   java   数学   多校2015   

原文地址:http://blog.csdn.net/u012860063/article/details/47281773

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!