码迷,mamicode.com
首页 > Web开发 > 详细

HDU 1045--Fire Net【DFS 经典】

时间:2015-08-04 23:08:34      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7912    Accepted Submission(s): 4505


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

技术分享

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
5 1 5 2 4
 


题意:与八皇后类似,炮台不能存在于同行同列,除非中间隔墙

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
char map[10][10];
int n;
int sum;

bool check(int x, int y){
    if(map[x][y] != '.') return false;
    for(int i = x - 1; i >= 0; --i){//向上搜索
        if(map[i][y] == '@') return false;
        if(map[i][y] == 'X') break;
    }
    for(int i = y - 1; i >= 0; --i){//向左搜索
        if(map[x][i] == '@') return false;
        if(map[x][i] == 'X') break;
    }
    return true;
}

void dfs(int x, int y, int ans){
    if(x == n) sum = max(ans, sum);
    else if(y == n) dfs(x + 1, 0, ans);
    else{
        for(int i = y; i < n; ++i){
            if(check(x, i)){
            map[x][i] = '@';//放置大炮
            dfs(x, i + 1, ans + 1);
            map[x][i] = '.';//回溯
            }
        }
        dfs(x + 1, 0, ans);
    }
}

int main (){
    while(scanf("%d", &n), n){
        for(int i = 0; i < n; ++i){
            scanf("%s", map[i]);
        }
        sum = 0;
        dfs(0, 0, 0);
        printf("%d\n", sum);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1045--Fire Net【DFS 经典】

标签:

原文地址:http://blog.csdn.net/hpuhjh/article/details/47282261

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!