码迷,mamicode.com
首页 > Web开发 > 详细

poj2531Network Saboteur

时间:2014-07-10 22:26:23      阅读:387      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   strong   width   

题目链接:

点我点我

题目:

Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8959   Accepted: 4190

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion

dfs,枚举的时候确定一部分的电脑数量,然后进行dfs回溯。。。。找出最大值。

只需要搜索一半即可,因为是对称的。。

代码为:

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=20+10;
int map[maxn][maxn],vis[maxn];
int n,max_value;
void dfs(int s,int num)
{
    if(num==0)
    {
        //cout<<"fuck"<<endl;
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i])
                continue;
            else
            {
                for(int j=1;j<=n;j++)
                {
                    if(vis[j])
                        continue;
                    else
                        sum=sum+map[i][j];
                }
            }
        }
      //  cout<<sum<<endl;
        max_value=max(sum,max_value);
        return;
    }
    for(int i=s;i<=n;i++)
    {
        vis[i]=1;
        dfs(i+1,num-1);
        vis[i]=0;
    }
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
              scanf("%d",&map[i][j]);
        max_value=0;
        for(int i=1;i<=n/2;i++)
           dfs(1,i);
        printf("%d\n",max_value);
    }
    return 0;
}


poj2531Network Saboteur,布布扣,bubuko.com

poj2531Network Saboteur

标签:des   style   http   color   strong   width   

原文地址:http://blog.csdn.net/u014303647/article/details/37651615

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!