码迷,mamicode.com
首页 > 移动开发 > 详细

A Mathematical Curiosity 水

时间:2015-08-08 18:20:03      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:c++   编程   iostream   

A - A Mathematical Curiosity
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input

1 10 1 20 3 30 4 0 0
 

Sample Output

Case 1: 2 Case 2: 4 Case 3: 5
 
AC代码:
#include <iostream>
using namespace std;
int main(){
    int N;
    cin>>N;
    while(N--){
        int n,m;
        int cns=1;
        while(cin>>n>>m&&(n||m)){
            int count=0;
            for(int i=1;i<n;++i){
                for(int j=i+1;j<n;++j){
                    if((i*i+j*j+m)%(i*j)==0)
                        count++;
                }
            }
            cout<<"Case "<<cns++<<": "<<count<<'\12';
        }
        if(N)cout<<'\12';
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

A Mathematical Curiosity 水

标签:c++   编程   iostream   

原文地址:http://blog.csdn.net/zp___waj/article/details/47360319

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!