码迷,mamicode.com
首页 > Windows程序 > 详细

hdu 5364 (bc#50 1001) Distribution money

时间:2015-08-09 17:03:24      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

Distribution money

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 276    Accepted Submission(s): 163


Problem Description
AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man‘s money is more than the sum of all others‘.He shoule be punished.Each one who get a part of money would write down his ID on that part.
 

 

Input
There are multiply cases.
For each case,there is a single integer n(1<=n<=1000) in first line.
In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man‘s ID.
 

 

Output
Output ID of the man who should be punished.
If nobody should be punished,output -1.
 

 

Sample Input
3 1 1 2 4 2 1 4 3
 

 

Sample Output
1 -1
 

 

Source
 
水.
比赛的时候傻逼两发,妈蛋
没读完就break了....
/*************************************************************************
    > File Name: code/bc/#50/1001.cpp
    > Author: 111qqz
    > Email: rkz2013@126.com 
    > Created Time: 2015年08月08日 星期六 19时02分16秒
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)  
typedef long long LL;
typedef unsigned long long ULL;
const int inf = 0x7fffffff;
int cnt[10005];
int n;
int x;
int main()
{
    while (scanf("%d",&n)!=EOF)
    {
    bool flag = false;
    memset(cnt,0,sizeof(cnt));
    for ( int i = 0 ; i < n ; i ++ )
    {
        scanf("%d",&x);
        cnt[x]++;
        if (flag) continue;
        if (cnt[x]>n/2)
        {
        flag = true;
        cout<<x<<endl;
        }
    }
    if (!flag)
    {
        cout<<-1<<endl;
    }
    }
    return 0;
}

 

 

hdu 5364 (bc#50 1001) Distribution money

标签:

原文地址:http://www.cnblogs.com/111qqz/p/4715231.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!