码迷,mamicode.com
首页 > 编程语言 > 详细

区间最小值(2) (线段树 更新区间)2015年 JXNU_ACS 算法组暑假第一次周赛

时间:2015-08-10 20:10:49      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:2015年 jxnu_acs 算法组暑假   线段树区间更新   线段树   区间最值   

区间最小值(2)

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 9

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

给定一个数字序列以及一些操作,查询任意给定区间内数字的最小值。

Input

输入包含多组测试数据,最多5组。
输入包含多组测试用例,每组测试用例的开头为一个整数n(1<=n<=100000),代表数字序列的长度。
接下去一行给出n个数字,代表数字序列。数字在int范围内。
下一行为一个整数t(1<=t<=10000),代表操作的次数。
最后t行,每行给出一个操作,1 l r代表查询区间 [l,r]的最小值,0 l r c代表将区间[l r]的值全部替换为c (1<=l<=r<=n),c在整形范围内。

Output

对于每个查询,输出区间[l,r]内的最小值。

Sample Input

5
1 2 3 4 5
7
1 1 5
0 1 3 6
1 1 4
1 2 3
0 2 2 0
1 1 2
1 3 5

Sample Output

1
4
6
0
4

Author

吴迎


迟到了五分钟才做了。。感觉做的是对的。虽然没能提交上。

找了一天了。。TM我终于找到怎么做了。。上午的时候其实就知道怎么更新区间了,只不过一个地方写错了

导致结果不对 就放弃了。。

今天下午尝试了那么多。。o(︶︿︶)o 唉 刚刚发现上午写的是对的。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int num[100005];
struct node
{
	int left,right,val;
}c[100005*4];
void build_tree(int l,int r,int root)
{
	c[root].left=l;
	c[root].right=r;
	if(l==r)
	{
		c[root].val=num[l];
		return ;
	}
	int mid=(l+r)/2;
	build_tree(l,mid,root*2);
	build_tree(mid+1,r,root*2+1);
	c[root].val=min(c[root*2].val,c[root*2+1].val);
}
void find_tree(int l,int r,int &min1,int root)
{
	if(c[root].left==l&&c[root].right==r)
	{
		min1=c[root].val;
		return ;
	}
	int mid=(c[root].left+c[root].right)/2;
	if(mid<l)
	find_tree(l,r,min1,root*2+1);
	else if(mid>=r)
	find_tree(l,r,min1,root*2);
	else
	{
		int min2;
		find_tree(l,mid,min1,root*2);
		find_tree(mid+1,r,min2,root*2+1);
		min1=min(min1,min2);
	}
	
}
void update_tree(int l,int r,int x,int root)
{
	if(c[root].left==c[root].right)
	{
		c[root].val=x;
		return ;
	}
	int mid=(c[root].left+c[root].right)/2;
	if(mid<l)
	update_tree(l,r,x,root*2+1);
	else if(mid>=r)
	update_tree(l,r,x,root*2);
	else
	{
		update_tree(l,mid,x,root*2);
		update_tree(mid+1,r,x,root*2+1);
		c[root].val=min(c[root*2].val,c[root*2+1].val);
	}
}
int main()
{
	int n,k;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=1;i<=n;i++)
		scanf("%d",&num[i]);
		build_tree(1,n,1);
		scanf("%d",&k);
		while(k--)
		{
			int a,b,min1,flag;
			scanf("%d",&flag);
			if(flag)
			{
				scanf("%d %d",&a,&b);
				find_tree(a,b,min1,1);
				printf("%d\n",min1);
			}
			else
			{
				int x;
				scanf("%d %d %d",&a,&b,&x);
				update_tree(a,b,x,1);
				//for(int i=1;i<=9;i++)
				//printf("[%d %d] %d\n",c[i].left,c[i].right,c[i].val);//自己测试的。。
			}
		}
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

区间最小值(2) (线段树 更新区间)2015年 JXNU_ACS 算法组暑假第一次周赛

标签:2015年 jxnu_acs 算法组暑假   线段树区间更新   线段树   区间最值   

原文地址:http://blog.csdn.net/su20145104009/article/details/47402633

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!