码迷,mamicode.com
首页 > 移动开发 > 详细

hdu 5099 Comparison of Android versions

时间:2015-08-13 22:27:46      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

Comparison of Android versions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1175    Accepted Submission(s): 472


Problem Description
As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B.

The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat).
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch.

The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010.

Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity.

Please develop a program to compare two Android build numbers.
 

Input
The first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process.

Each test case consists of a single line containing two build numbers, separated by a space character.
 

Output
For each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows:

● Print "<" if the release of the first build number is lower than the second one;
● Print "=" if the release of the first build number is same as he second one;
● Print ">" if the release of the first build number is higher than the second one.

Continue to output the result of date comparison as follows:
● Print "<" if the date of the first build number is lower than the second one;
● Print "=" if the date of the first build number is same as he second one;
● Print ">" if the date of the first build number is higher than the second one.

If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
 

Sample Input
2 FRF85B EPF21B KTU84L KTU84M
 

Sample Output
Case 1: > > Case 2: = <
 

Source

2014上海全国邀请赛——题目重现(感谢上海大学提供题目)  

这题考的是英语,唉,英语是硬伤,,具体已经注释了 

#include<stdio.h>
#include<string.h>
#define M 10
char str[M],ch[M];
char a[M],b[M];
int main(){
	int t,cas=1;
	scanf("%d",&t);
	while(t--){
		memset(a,'\0',sizeof(a));
		memset(b,'\0',sizeof(b));
		scanf("%s %s",str,ch);
		printf("Case %d: ",cas++);
		//先比较第一个字母 
		if(str[0]==ch[0])
			printf("= ");
		else if(str[0]>ch[0])
			printf("> ");
		else 
			printf("< ");
		//如果第二个字母一样的话,直接比较后四个 
		if(str[1]==ch[1]){
			strncpy(a,str+2,4);
			strncpy(b,ch+2,4);
			if(strcmp(a,b)<0)
				printf("<");
			else if(strcmp(a,b)==0)
				printf("=");
			else 
				printf(">");	 
		}else{//不一样就比较后三个 
			strncpy(a,str+2,3);
			strncpy(b,ch+2,3);
			if(strcmp(a,b)<0)
				printf("<");
			else if(strcmp(a,b)==0)
				printf("=");
			else 
				printf(">");
			 
		}
		printf("\n");
	}
	return 0;
} 


hdu 5099 Comparison of Android versions

标签:

原文地址:http://blog.csdn.net/ling_du/article/details/47618137

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!