码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 2647--Reward【拓扑排序】

时间:2015-08-14 13:48:16      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5636    Accepted Submission(s): 1712


Problem Description
Dandelion‘s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a‘s reward should more than b‘s.Dandelion‘s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work‘s reward will be at least 888 , because it‘s a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a‘s reward should be more than b‘s.
 

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it‘s impossible to fulfill all the works‘ demands ,print -1.
 

Sample Input
2 1 1 2 2 2 1 2 2 1
 

Sample Output
1777 -1
题意:

 老板要给很多员工发奖金, 但是部分员工有个虚伪心态, 认为自己的奖金必须比某些人高才心理平衡; 但是老板很人道, 想满足所有人的要求, 并且很吝啬,想画的钱最少,问满足所有人的前提下最少花多少钱。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define maxn 11000
using namespace std;

char map[maxn];
int indu[maxn];
int head[maxn], cnt;
int n, m;
int a[maxn];

struct node {
    int u, v, next;
};

node edge[110000];

void init(){
    cnt = 0;
    memset(head, -1, sizeof(head));
    memset(indu, 0, sizeof(indu));
    for(int i = 1; i <= n; ++i)//所有人的工资一开始都为888
        a[i] = 888;
}

void add(int u, int v){
    edge[cnt] = {u, v, head[u]};
    head[u] = cnt++;
}

void input(){
    while(m--){
        int a, b;
        scanf("%d%d", &b, &a);
        add(a, b);//注意是反向的, wa了一次
        indu[b]++;
    }
}

void topsort(){
    queue<int >q;
    int sum = 0;
    int ans = 0;
    for(int i = 1; i <= n; ++i){
        if(!indu[i]){
            q.push(i);
            ans++;
        }
    }
    while(!q.empty()){
        int u = q.front();
        sum += a[u];
        q.pop();
        for(int i = head[u]; i != -1; i = edge[i].next){
            int v = edge[i].v;
            indu[v]--;
            if(!indu[v]){
                q.push(v);
                a[v] = a[u] + 1;//保证后一个人的工资比前一个人的工资高
                ans++;
            }
        }
    }
    if(ans == n)
        printf("%d\n", sum);
    else
        printf("-1\n");
}

int main (){
    while(scanf("%d%d", &n, &m) != EOF){
        init();
        input();
        topsort();
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 2647--Reward【拓扑排序】

标签:

原文地址:http://blog.csdn.net/hpuhjh/article/details/47659891

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!